Skip to content

fix(deps): Raise minimum Python to 3.10 and bump vulnerable dependencies - #261

Merged
erezrokah merged 1 commit into
mainfrom
agent/security-ATH-1511
Nov 3, 2026
Merged

erezrokah merged 1 commit into
mainfrom
agent/security-ATH-1511

Conversation

@cloudquery-ci

@cloudquery-ci cloudquery-ci Bot commented Nov 3, 2026

Copy link
Copy Markdown
Contributor

Fixes the open Dependabot alerts on this repository:

Changes:

  • requires-python is now >=3.10, with the 3.9 classifier and the README prerequisite dropped. pyarrow 23.0.1 needs Python 3.10, and the old range kept pyarrow 21.0.0 in the lock file for 3.9. That is the version alert 5 flags.
  • uv.lock is re-locked with uv 0.12.18 (the version CI uses). Only Pygments and setuptools are upgraded. The 3.9-only entries are removed and pyarrow stays at 23.0.1.

Testing:

  • uv lock --check passes.
  • uv sync --frozen, make test (2 passed) and make fmt-check pass locally on Python 3.11.
  • CI runs the same on Python 3.14.

Python 3.9 is no longer supported by cloudquery-plugin-pb, so this is a consumer-facing change.

Fixes https://linear.app/env-zero/issue/ATH-1511/fix-open-dependabot-alerts-in-cloudqueryplugin-pb-python

@cloudquery-ci
cloudquery-ci Bot marked this pull request as ready for review November 3, 2026 15:48
@cloudquery-ci
cloudquery-ci Bot requested a review from a team as a code owner November 3, 2026 15:48
@cloudquery-ci
cloudquery-ci Bot requested review from marianogappa and removed request for a team November 3, 2026 15:48
@erezrokah
erezrokah merged commit 0482ec2 into main Nov 3, 2026
7 checks passed
@erezrokah
erezrokah deleted the agent/security-ATH-1511 branch November 3, 2026 16:58
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant